Michael McNamara https://blog.michaelfmcnamara.com technology, networking, virtualization and IP telephony Sun, 31 Oct 2021 01:20:18 +0000 en-US hourly 1 https://wordpress.org/?v=6.7.2 Juniper EX4300 – no half duplex support https://blog.michaelfmcnamara.com/2017/09/juniper-ex4300-no-half-duplex-support/ https://blog.michaelfmcnamara.com/2017/09/juniper-ex4300-no-half-duplex-support/#comments Sat, 09 Sep 2017 14:35:08 +0000 https://blog.michaelfmcnamara.com/?p=6095 I’ve recently started deploying the Juniper EX4300 in a large campus rollout (more on that in a future post) and during an forklift upgrade last night we ran into an interesting issue. We have some Wattstopper lighting control systems that require 10Mbps half-duplex connections. We quickly discovered that the Juniper EX4300 doesn’t support half duplex, it only supports full duplex.

If you have a look at the Juniper documentation for the ELS hardware you’ll notice the following statement half-way down the page.

That explains why we weren’t able to find the link-mode option in the CLI configuration under the interface branch.

In the end we were able to get the Wattstopper working at 10Mbps full duplex.

It’s not a huge deal but it could certainly get entertaining trying to connect some of the older HVAC and SCADA solutions that utilize much older 10Mbps NICs and hubs. There was a post here that suggests the issue is related to the PHY and MACSEC.

If I get additional feedback from Juniper I’ll post it here.

Cheers!

Update: October 23, 2017

Half-duplex link support (EX4300 switches)—Starting with Junos OS 14.1X53-D40, half-duplex communication is supported on all built-in network copper ports on EX4300 switches. Half-duplex is bidirectional communication, but signals can flow in only one direction at a time. Full-duplex communication means that both ends of the communication can send and receive signals at the same time.Half-duplex is configured by default on EX4300 switches. If the link partner is set to autonegotiate the link, then the link is autonegotiated to full duplex or half duplex. If the link is not set to autonegotiation, then the EX4300 link defaults to half-duplex unless the interface is explicitly configured for full duplex.
To explicitly configure full duplex:
[edit]
user@switch# set interfaces interface-name speed 10m-or-100m
[edit]
user@switch# set interfaces interface-name ether-options no-auto-negotiate
To verify a half-duplex setting:
user@switch> show interfaces interface-name extensive

]]>
https://blog.michaelfmcnamara.com/2017/09/juniper-ex4300-no-half-duplex-support/feed/ 5
VLANs and IP Routing on an Cisco Switch and Router https://blog.michaelfmcnamara.com/2016/06/vlans-and-ip-routing-on-an-cisco-switch-and-router/ Thu, 16 Jun 2016 23:15:44 +0000 https://blog.michaelfmcnamara.com/?p=5753 One of the most popular blog posts I’ve written in the past five years is, VLANs and IP Routing on an Ethernet Routing Switch. It continues to be the top post on my blog so I decided to write a follow-up using Cisco equipment. This has been covered many times on the Internet before but I’m going to try and add my spin to it here. In this example I’m going to take a Cisco 1921 router and a Cisco 3560-CX switch and show two different examples of how you could design a simple topology.

Example 1 – VLAN Routing on Router (Layer 2 Switching)

In the old days when we only had Layer 2 switching we could create an 802.1Q/ISL trunk between the switch and the router and we would route from the physical router itself. The switch would have an IP address just for management and was generally incapable of routing traffic. The router would have the IP address for every VLAN and that would be the default gateway for every device in that specific VLAN.  If there is no WAN or Internet link this topology is often referred to as a router on a stick. The topology might look something like this;

VLAN-IP-Routing-Cisco-2

This was and still is a widely accepted design although it has significant limitations since the legacy Cisco router is generally not capable of wire speed routing. In the case of the Cisco 1921 it can handle anywhere from 68Mbps – 110Mbps depending on packet size and configured features.  Lots of people upgrade their Layer 2 switches to Gigabit only to later figure out that they can’t achieve Gigabit speeds between VLANs because they are routing between VLANs on a legacy software based router.

Example 2 – VLAN Routing on Switch (Layer 3 Switching)

The newer accepted design is to do Layer 3 switching (routing) right on the switch itself, no need to include the legacy router. The IP interface for each VLAN is moved to the actual switch and traffic between those VLANs doesn’t need to leave the physical switch. That topology might look something like this;

VLAN-IP-Routing-Cisco-1

In this design all the internal routing occurs on the Cisco 3560 which is capable or wire speed switching and routing thanks to the ASIC hardware. In this case we can now achieve near Gigabit transfer speeds between the VLANs, the only real variable is the speed of the actual source and destination device – servers, laptops, desktops, etc. We isolate the WAN router so it’s only required when we need to communicate with the WAN or Internet. We might only have a 50Mbps Internet connection so the legacy router is capable of handling that amount of traffic and provides additional features such as NAT for hiding our private network from the public Internet.

So what’s the configuration look like, it’s actually pretty straight forward;

Example 1 – Cisco 3560-CX Switch

enable
config t

username mike privilege 15 secret mypassword
enable secret myenable

vlan 100
 name "VLAN_100"
vlan 200
 name "VLAN_200"

inter vlan 1
 ip address 192.168.1.10 255.255.255.0
 no shut

inter range gig0/1-2
 switchport mode access
 switchport access vlan 1
inter range gig0/3-4
 switchport mode access
 switchport access vlan 100
inter range gig0/5-6
 switchport mode access
 switchport access vlan 200
inter gig0/10
 switchport mode trunk

line vty 0 4
 login local 

Example 1 – Cisco 1921 Router

enable
config t

username mike privilege 15 secret mypassword
enable secret myenable

inter gig0/0.1
encapsulation dot1q 1
ip address 192.168.1.1 255.255.255.0
description VLAN_1
exit

inter gig0/0.100
encapsulation dot1q 100
ip address 192.168.100.1 255.255.255.0
description VLAN_100
exit

inter gig0/0.200
encapsulation dot1q 200
ip address 192.168.200.1 255.255.255.0
description VLAN_200
exit

line vty 0 4
 login local

Let’s look at the commands needed for the second example. In this case you’ll notice that I added a few IP routes to the configuration. In this case I added a default route on the Cisco 3560 forwarding traffic to the Cisco 2921. I also added IP routes to the Cisco 2921 for the IP subnets that we configured on the Cisco 3560. It’s not enough that the network knows where to send traffic to the destination. The network also needs to know how to send the replies back to the source devices, so we need routes in both directions.

Example 2 – Cisco 3560-CX Switch

enable
config t

username mike privilege 15 secret mypassword
enable secret myenable

vlan 100
 name "VLAN_100"
vlan 200
 name "VLAN_200"

inter vlan 1
 ip address 192.168.1.1 255.255.255.0
 no shut

inter vlan 100
 ip address 192.168.100.1 255.255.255.0
 no shut

inter vlan 200
 ip address 192.168.200.1 255.255.255.0


inter range gig0/1-2
 switchport mode access
 switchport access vlan 1
inter range gig0/3-4
 switchport mode access
 switchport access vlan 100
inter range gig0/5-6
 switchport mode access
 switchport access vlan 200

inter gig0/10
 desc UPLINK_C1921
 no switchport
 ip address 192.168.255.1 255.255.255.252
 no shut

ip route 0.0.0.0 0.0.0.0 192.168.255.2

line vty 0 4
 login local 

Example 2 – Cisco 1921 Router

enable
config t

username mike privilege 15 secret mypassword
enable secret myenable

inter gig0/0
 descr UPLINK_C3560
 ip address 192.168.255.2 255.255.255.0
 exit

ip route 192.168.1.0 255.255.255.0 192.168.255.1 
ip route 192.168.100.0 255.255.255.0 192.168.255.1 
ip route 192.168.200.0 255.255.255.0 192.168.255.1 

line vty 0 4
 login local

Cheers!

Note: Thanks to Cisco for providing the equipment I’m using today, it’s a small switch and router but it’s really helpful when working through example topologies to work on real equipment.

]]>
Nortel Ethernet Switch Matrix https://blog.michaelfmcnamara.com/2008/10/nortel-ethernet-switch-matrix/ https://blog.michaelfmcnamara.com/2008/10/nortel-ethernet-switch-matrix/#comments Sun, 05 Oct 2008 03:30:57 +0000 http://blog.michaelfmcnamara.com/?p=457 Nortel has released an updated Ethernet Switch matrix which I’ve uploaded to my site.

Cheers!

]]>
https://blog.michaelfmcnamara.com/2008/10/nortel-ethernet-switch-matrix/feed/ 2
How to cascade a stack of Nortel switches? https://blog.michaelfmcnamara.com/2008/08/how-to-cascade-a-stack-of-nortel-switches/ https://blog.michaelfmcnamara.com/2008/08/how-to-cascade-a-stack-of-nortel-switches/#comments Sun, 10 Aug 2008 14:00:14 +0000 http://blog.michaelfmcnamara.com/?p=260 I was recently asked “How to cascade a stack of Nortel switches?”. I thought that’s a pretty easy question but probably one that hasn’t been covered well by the manuals or other material. In short you just need to physically connect the switches using the supplied cascade/stack cables. On the back of each switch you’ll find a selector switch with two options, “Base” and “non-Base”. Only one switch in the stack can be set to Base and I generally set the topmost switch (physically looking at the stack) to the Base switch. That’s really all there is to it, the software will detect the presence of the cascade/stack cables and the switches will each join the stack, numbering themselves as “Unit 1 – Base”, “Unit 2”, “Unit 3”, and so on. The ports will then be referenced as 1/1, 2/1, 3/1, etc.

There are of course some caveats, aren’t there always caveats!. You can only stack specific switches with themselves. For instance you can only stack a Nortel Ethernet Routing Switch 5500 series switch (5510, 5520, 5530) with anther Nortel Ethernet Routing Switch 5500 series. You can’t stack a Nortel Ethernet Routing Switch 4500 series with a Nortel Ethernet Routing Switch 5500 series. The stack cables are very different so it shouldn’t be too hard to figure out. The switches must have the same software version of code on them in order to stack properly. The newer Ethernet Routing Switch 4500/5500 series switches will try to automatically upgrade any switch that is added to the stack and isn’t running the appropriate software version.

You can cascade/stack older Ethernet Switch 450, Ethernet Switch 460 and Ethernet Switch 470 switches. I would not advise stacking the Ethernet Switch 450 with either the ES460 or ES470 even though Nortel claims you can. There’s no issue stacking a Nortel Ethernet Switch 460 with the Ethernet Switch 470.

Cheers!

]]>
https://blog.michaelfmcnamara.com/2008/08/how-to-cascade-a-stack-of-nortel-switches/feed/ 45