Michael McNamara https://blog.michaelfmcnamara.com technology, networking, virtualization and IP telephony Sat, 12 Feb 2011 19:21:31 +0000 en-US hourly 1 https://wordpress.org/?v=6.7.2 RIP on an Ethernet Routing Switch https://blog.michaelfmcnamara.com/2011/02/rip-on-an-ethernet-routing-switch/ https://blog.michaelfmcnamara.com/2011/02/rip-on-an-ethernet-routing-switch/#comments Thu, 10 Feb 2011 22:00:59 +0000 http://blog.michaelfmcnamara.com/?p=1951 In this post I’m going to continue to explore the stackable Avaya Ethernet Routing Switches.  I’m going to demonstrate how to configure RIP between an Avaya Ethernet Routing Switch 4548GT-PWR and an Avaya Ethernet Routing Switch 5520-48T-PWR. There’s really not a whole lot to it but there seems to be some demand for these quick little guides so I’m happy to accommodate.

In the diagram to the right you can see that I have both switches connected over VLAN 1 by a MultiLink Trunk. I’m going to create VLAN 25 and VLAN 75 on the ERS 4548 while I create VLAN 100 and VLAN 200 on the ERS 5520. I’ll also announce a default route from the ERS 4548 to the ERS 5520 via RIP.

Ethernet Routing Switch 4548

Let’s start by enabling RIP globally and specify the IP interfaces we’ll want to participate in RIP;

router rip
router rip enable
network 192.168.1.25
network 192.168.25.1
network 192.168.75.1

Next we’ll configure RIP on VLAN 1 and enable default-supply since this switch will be advertising a default route for the network. We’ll also set the RIP interface to only utilize RIP v2. This will be the interface that will communicate with the ERS 5520 switch.

interface vlan 1
ip rip enable
ip rip default-supply enable
ip rip receive version rip2
ip rip send version rip2
exit

Next we’ll configure RIP on VLAN 25 only since we don’t expect to connect any switches or routers to this VLAN we’ll essentially place RIP in a passive mode by disabling listen and supply. In the mindset of being consistent we’ll set the interface to only utilize RIP v2 even though it won’t be transmitting or listening.

interface vlan 25
ip rip enable
no ip rip listen enable
no ip rip supply enable
ip rip receive version rip2
ip rip send version rip2
exit

We need to repeat the same configuration above but for VLAN 75 since we don’t expect to share any routing information with any switches or routers on VLAN 75.

interface vlan 75
ip rip enable
no ip rip listen enable
no ip rip supply enable
ip rip receive version rip2
ip rip send version rip2
exit

As I mentioned earlier, we’re going to advertise a default route from the ERS 4548 to the rest of the network. In order to accomplish that task we need a route policy (it’s called a route map on the stackable switches but a route policy on the chassis switches). We need to make sure that we match 0.0.0.0/0 and not just inject 0.0.0.0/0. This approach will allow RIP to stop advertising 0.0.0.0/0 if the route disappears from the routing table on our originating switch. In the examples below there will be a static default route to 0.0.0.0/0 via 192.168.1.1.

ip prefix-list default_route 0.0.0.0/0
route-map rip_pol_1 1
route-map rip_pol_1 1 enable
route-map rip_pol_1 permit 1 enable
route-map rip_pol_1 permit 1 match network default_route

Now that we have the route-map we need to apply it to the RIP interface on VLAN 1 since that’s the interface that will be communicating with the ERS 5520.

interface vlan 1
ip rip out-policy rip_pol_1
exit

Ethernet Routing Switch 5520

Let’s start by enabling RIP globally and specify the IP interfaces we’ll want to participate in RIP;

router rip
router rip enable
network 192.168.1.50
network 192.168.100.1
network 192.168.200.1

Next we’ll configure RIP on VLAN 1 and enable default-listen since this switch will be learning a default route from the ERS 4548 on this interface. We’ll also set the RIP interface to only utilize RIP v2.

interface vlan 1
ip rip enable
ip rip default-listen enable
ip rip receive version rip2
ip rip send version rip2
exit

Next we’ll configure RIP on VLAN 100 only since we don’t expect to connect any switches or routers to this VLAN we’ll essentially place RIP in a passive mode by disabling listen and supply. In the mindset of being consistent we’ll set the interface to only utilize RIP v2 even though it won’t be transmitting or listening.

interface vlan 100
ip rip enable
ip rip receive version rip2
ip rip send version rip2
no ip rip listen enable
no ip rip supply enable
exit

We need to repeat the same configuration above but for VLAN 200 since we don’t expect to share any routing information with any switches or routers on VLAN 200.

interface vlan 200
ip rip enable
ip rip receive version rip2
ip rip send version rip2
no ip rip listen enable
no ip rip supply enable
exit

Those are the commands that you’ll need to get both switches exchanging dynamic routing information via RIP v2.

Ethernet Routing Switch 4548 (show commands)

Here are some operational commands that can be used to check the status of RIP and the routing table.

4548GT-PWR#show ip rip
Default Import Metric:  8
Domain:
HoldDown Time:  120
Queries:  1
Rip:  Enabled
Route Changes:  8
Timeout Interval:  180
Update Time:  30

You can see below the status of the RIP interface on VLAN 1, notice the status of Dflt Supply is set to true and the policy ‘RIP Out Policy’ is applied that we previously configured.

4548GT-PWR(config)#show ip rip interface vlan 1
IP Address      Enable Send           Receive      Advertise When Down
--------------- ------ -------------- ------------ -------------------
192.168.1.25    true   ripVersion2    rip2         false

RIP  Dflt   Dflt   Trigger AutoAgg
IP Address      Cost Supply Listen Update  Enable  Supply Listen Poison Proxy
--------------- ---- ------ ------ ------- ------- ------ ------ ------ -----
192.168.1.25    1    true   false  false   false   true   false  false  false

IP Address      RIP In Policy
--------------- ---------------------------------------------------------------
192.168.1.25

IP Address      RIP Out Policy
--------------- ---------------------------------------------------------------
192.168.1.25    rip_pol_1

IP Address      Holddown Timeout
--------------- -------- -------
192.168.1.25    120      180

Finally the routing table for the ERS 4548, you can see the static default route (notice the S for static) and you can see the two RIP routes (notice the R for RIP).

4548GT-PWR#show ip route
===============================================================================
Ip Route
===============================================================================
DST             MASK            NEXT            COST    VLAN PORT PROT TYPE PRF
-------------------------------------------------------------------------------
0.0.0.0         0.0.0.0         192.168.1.1     1        1    1     S  IB     5
192.168.1.0     255.255.255.0   192.168.1.25    1        1    ----  C  DB     0
192.168.25.0    255.255.255.0   192.168.25.1    1        25   ----  C  DB     0
192.168.75.0    255.255.255.0   192.168.75.1    1        75   ----  C  DB     0
192.168.100.0   255.255.255.0   192.168.1.50    2        1    T#1   R  IB   100
192.168.200.0   255.255.255.0   192.168.1.50    2        1    T#1   R  IB   100
Total Routes: 6
-------------------------------------------------------------------------------
TYPE Legend:
I=Indirect Route, D=Direct Route, A=Alternative Route, B=Best Route, U=Unresolv
ed Route, N=Not in HW

Here’s the configuration we used on the ERS 4548 in this post.

4548GT-PWR#show running-config module l3-protocols
! Embedded ASCII Configuration Generator Script
! Model = Ethernet Routing Switch 4548GT-PWR
! Software version = v5.4.1.012
!
! Displaying only parameters different to default
!================================================
enable
configure terminal
!
! *** L3 Protocols ***
!

! --- Proxy ARP ---

! --- UDP Broadcast Forwarding ---

! --- Route Policies ---

ip prefix-list "default_route" 0.0.0.0/0
route-map "rip_pol_1" 1
route-map "rip_pol_1" 1 enable
route-map "rip_pol_1" 1 match network "default_route"

! --- OSPF ---

! --- RIP ---

router rip
router rip enable
exit
enable
configure terminal
interface vlan 1
ip rip default-supply enable
ip rip out-policy "rip_pol_1"
ip rip enable
exit
interface vlan 25
no ip rip listen enable
ip rip receive version rip2
ip rip send version rip2
no ip rip supply enable
ip rip enable
exit
interface vlan 75
no ip rip listen enable
ip rip receive version rip2
ip rip send version rip2
no ip rip supply enable
ip rip enable
exit

Ethernet Routing Switch 5520 (show commands)

Here are some operational commands that can be used to check the status of RIP and the routing table.

5520-48T-PWR#show ip rip
Default Import Metric:  8
Domain:
HoldDown Time:  120
Queries:  1
Rip:  Enabled
Route Changes:  6
Timeout Interval:  180
Update Time:  30

You can see below the status of the RIP interface on VLAN 1, notice the status of Dflt Listen is set to true.

5520-48T-PWR#show ip rip interface vlan 1
IP Address      Enable Send           Receive      Advertise When Down
--------------- ------ -------------- ------------ -------------------
192.168.1.50    true   ripVersion2    rip2         false

RIP  Dflt   Dflt   Trigger AutoAgg
IP Address      Cost Supply Listen Update  Enable  Supply Listen Poison Proxy
--------------- ---- ------ ------ ------- ------- ------ ------ ------ -----
192.168.1.50    1    false  true   false   false   true   true   false  false

IP Address      RIP In Policy
--------------- ---------------------------------------------------------------
192.168.1.50

IP Address      RIP Out Policy
--------------- ---------------------------------------------------------------
192.168.1.50

IP Address      Holddown Timeout
--------------- -------- -------
192.168.1.50    120      180

Finally the routing table for the ERS 4548, you can see the two RIP routes (notice the R for RIP).

5520-48T-PWR#show ip route
===============================================================================
Ip Route
===============================================================================
DST             MASK            NEXT            COST    VLAN PORT PROT TYPE PRF
-------------------------------------------------------------------------------
0.0.0.0         0.0.0.0         192.168.1.25    2        1    T#1   R  IB   100
192.168.1.0     255.255.255.0   192.168.1.50    1        1    ----  C  DB     0
192.168.25.0    255.255.255.0   192.168.1.25    2        1    T#1   R  IB   100
192.168.75.0    255.255.255.0   192.168.1.25    2        1    T#1   R  IB   100
192.168.100.0   255.255.255.0   192.168.100.1   1        100  ----  C  DB     0
192.168.200.0   255.255.255.0   192.168.200.1   1        200  ----  C  DB     0
Total Routes: 6
-------------------------------------------------------------------------------
TYPE Legend:
I=Indirect Route, D=Direct Route, A=Alternative Route, B=Best Route, E=Ecmp Route, U=Unresolved Route, N=Not in HW

Here’s the configuration we used on the ERS 5520 in this post.

5520-48T-PWR#show running-config module l3-protocols
! Embedded ASCII Configuration Generator Script
! Model = Ethernet Routing Switch 5520-48T-PWR
! Software version = v6.2.1.002
!
! Displaying only parameters different to default
!================================================
enable
configure terminal
!
! *** L3 Protocols ***
!

! --- Proxy ARP ---

! --- UDP Broadcast Forwarding ---

! --- VRRP ---

! --- Route Policies ---

! --- OSPF ---

! --- RIP ---

router rip
router rip enable
exit
enable
configure terminal
interface vlan 1
ip rip default-listen enable
ip rip receive version rip2
ip rip send version rip2
ip rip enable
exit
interface vlan 100
no ip rip listen enable
ip rip receive version rip2
ip rip send version rip2
no ip rip supply enable
ip rip enable
exit
interface vlan 200
no ip rip listen enable
ip rip receive version rip2
ip rip send version rip2
no ip rip supply enable
ip rip enable
exit

Cheers!

]]>
https://blog.michaelfmcnamara.com/2011/02/rip-on-an-ethernet-routing-switch/feed/ 4